0 votes
by (120 points)

I am a new user and I testing the camera, I installed the prebuilt image Jetson_nano_A02_B01_R32.2.1_20200317_VEYE_MIPI_327.img, I connected it, and run: 

gst-inspect-1.0 --version

the result: 

gst-inspect-1.0 version 1.14.5

GStreamer 1.14.5

https://launchpad.net/distros/ubuntu/+source/gstreamer1.0

Finally when I execute: 

dmesg | grep “veye327”
my result is:
[    1.752155] veye327 6-003b: probing v4l2 sensor
[    1.752371] veye327 6-003b: tegracam sensor driver:veye327_v2.0.6
[    1.753049] veye327 6-003b: veye327_board_setup: error during i2c read probe (-121)
[    1.760762] veye327 6-003b: board setup failed
[    1.765329] veye327: probe of 6-003b failed with error -121
I hope someone could help me

1 Answer

0 votes
by (2.6k points)

Hi,

1. Please check the hardware connection. VEYE-MIPI-327 need a 5V power supply.

http://wiki.veye.cc/index.php/VEYE_MIPI_290/327_for_Jetson_Nano

2. Please chech the i2c communication via this:

http://wiki.veye.cc/index.php/VEYE_MIPI_290/327_for_Jetson_Nano#Video_Control_Toolkits_Manual

http://wiki.veye.cc/index.php/VEYE-MIPI-290/327_i2c/

./veye_mipi_i2c.sh -r -f devid

by (120 points)
Hello, I downloaded Jetson_nano_B01_Jetpack4.4_R32.4.3_20200716_VEYE_MIPI_327.img  SO from google driver and installed it , but when I Check system status I executed:
gst-inspect-1.0 --version
result:
gst-inspect-1.0 version 1.14.5
GStreamer 1.14.5
https://launchpad.net/distros/ubuntu/+source/gstreamer1.0
Then I run:
dmesg | grep “veye327”
result:
shows anything
Finally I executed
ls /dev/video*
showed:
File or directory does not exist

I hope you can help me.
欢迎来到 Veye Q&;A ,有什么不懂的可以尽管在这里提问,你将会收到社区其他成员的回答。
...