0 投票
用户: (120 分)
I'm trying to turn on daynightmode, but i keep getting an error

if I enter the command without "sudo" then I get an error "should be root"

if I enter the command with "sudo" I get an error

./veye_mipi_i2c.sh: 593: ./veye_mipi_i2c.sh: cannot create /sys/bus/i2c/devices/i2c-6/bus_clk_rate: Directory nonexistent
====I2C write:<0x3b> <0x7> <0xfe>====
Failed to set I2C address
w daynightmode is 0xfe

1个回答

0 投票
用户: (2.7k 分)

Hi,

which platform do you use? 

pls notice this:

http://wiki.veye.cc/index.php/VEYE_CS_Camera_for_Jetson_TX2#Video_Control_Toolkits_Manual

  • i2c bus description:

For AGX-Xavier and TX2, ADP-N1 has 6 MIPI CSI-2 interface [A-F],the corresponding i2c address is[30-35].

For Xavier NX, the corresponding i2c address is 9 and10.

It is also the same as the 3X part of dmesg message:

subdev veye327 3X-003b bound

subdev csimx307 3X-003b bound

subdev cssc132 3X-003b bound

using -b option to identify which bus you want to use.

用户: (120 分)
This is on Raspberry Pi.
用户: (2.7k 分)
we upload the jetson platform version before, sorry!
pls download the file from github now. thanks!
用户: (120 分)
Thanks I'll test it tomorrow when I get into the office and give feed back then.
用户: (120 分)
The new upload works. Thanks!
欢迎来到 Veye Q&;A ,有什么不懂的可以尽管在这里提问,你将会收到社区其他成员的回答。
...